Lab 4: Configuring VLANs and Inter-VLAN Routing Using Cisco Packet Tracer

University Caribbean Maritime University
Subject Computer Networking

Lab 4: Implementing Inter-VLAN Routing

General Instructions for All Labs

  1. Tools Required:
    • Cisco Packet Tracer: Ensure you have the latest version installed.
    • Access Credentials: Username and password for network devices, if necessary.
    • Reference Materials: Course slides, textbook chapters, and any supplementary resources provided.
  2. Submission Requirements:
    • Lab Report Document: A PDF or Word document containing:
      • Introduction: Brief overview of the lab objectives.
      • Step-by-Step Execution: Detailed description of the steps taken.
      • Screenshots: Clear images of key components and configurations.
      • Feedback: Personal insights on the lab experience.
      • Learnings: Summary of what was learned and how it applies to real-world scenarios.
  3. Assessment Criteria:
    • Accuracy: Correctness of configurations and network setups.
    • Completeness: Inclusion of all required steps and components.
    • Clarity: Clear explanations and well-organized report.
    • Evidence: Quality and relevance of screenshots provided.

Lab 4: Configuring VLANs and Inter-VLAN Routing

Objective:

  • Create and assign VLANs on switches.
  • Configure inter-VLAN routing to enable communication between different VLANs.

Required Tools:

  • Cisco Packet Tracer
  • Access to course slides on Data Link Layer and VLANs

Step-by-Step Instructions:

  1. Launch Cisco Packet Tracer:
    • Open Cisco Packet Tracer.
  2. Create a Network Topology:
    • Add Devices:
      • Drag and drop two Switches, one Router, and four Generic PCs.
    • Connect Devices:
      • Connect Switch1 to Router via GigabitEthernet0/0.
      • Connect Switch2 to Router via GigabitEthernet0/1.
      • Connect PC1 and PC2 to Switch1.
      • Connect PC3 and PC4 to Switch2.
  3. Configure VLANs on Switches:
    Switch1> enable
    Switch1# configure terminal
    Switch1(config)# vlan 10
    Switch1(config-vlan)# name Sales
    Switch1(config-vlan)# exit
    Switch1(config)# vlan 20
    Switch1(config-vlan)# name Engineering
    Switch1(config-vlan)# exit
    • Assign Ports to VLANs:
      Switch1(config)# interface FastEthernet0/1
      Switch1(config-if)# switchport mode access
      Switch1(config-if)# switchport access vlan 10
      Switch1(config-if)# exit
      Switch1(config)# interface FastEthernet0/2
      Switch1(config-if)# switchport mode access
      Switch1(config-if)# switchport access vlan 20
      Switch1(config-if)# exit

      Do You Need Assignment of This Question

  4. Configure IP Addresses for VLANs on the Router:
    Router> enable
    Router# configure terminal
    Router(config)# interface GigabitEthernet0/0
    Router(config-if)# no shutdown
    Router(config-if)# exit
    Router(config)# interface GigabitEthernet0/0.10
    Router(config-subif)# encapsulation dot1Q 10
    Router(config-subif)# ip address 192.168.10.1 255.255.255.0
    Router(config-subif)# exit
    Router(config)# interface GigabitEthernet0/0.20
    Router(config-subif)# encapsulation dot1Q 20
    Router(config-subif)# ip address 192.168.20.1 255.255.255.0
    Router(config-subif)# exit
    Router(config)# exit
    Router# write memory
  5. Assign IP Addresses to PCs:
    • PC1 (VLAN 10 – Sales):
      • IP Address: 192.168.10.2
      • Subnet Mask: 255.255.255.0
      • Default Gateway: 192.168.10.1
    • PC2 (VLAN 10 – Sales):
      • IP Address: 192.168.10.3
      • Subnet Mask: 255.255.255.0
      • Default Gateway: 192.168.10.1
    • PC3 (VLAN 20 – Engineering):
      • IP Address: 192.168.20.2
      • Subnet Mask: 255.255.255.0
      • Default Gateway: 192.168.20.1
    • PC4 (VLAN 20 – Engineering):
      • IP Address: 192.168.20.3
      • Subnet Mask: 255.255.255.0
      • Default Gateway: 192.168.20.1
  6. Configure Trunk Ports on Switches:
    Switch1(config)# interface GigabitEthernet0/24
    Switch1(config-if)# switchport mode trunk
    Switch1(config-if)# switchport trunk allowed vlan 10,20
    Switch1(config-if)# exit
    Switch2(config)# interface GigabitEthernet0/24
    Switch2(config-if)# switchport mode trunk
    Switch2(config-if)# switchport trunk allowed vlan 10,20
    Switch2(config-if)# exit
  7. Verify VLAN Configuration:
    • On Switch1:
      Switch1# show vlan brief
      • Ensure VLANs 10 and 20 are listed with assigned ports.
    • On Router:
      Router# show ip interface brief
      Router# show running-config interface GigabitEthernet0/0.10
      Router# show running-config interface GigabitEthernet0/0.20
  8. Test Inter-VLAN Connectivity:
    • From PC1 (VLAN 10), ping PC3 (VLAN 20):
      ping 192.168.20.2
    • From PC3 (VLAN 20), ping PC1 (VLAN 10):
      ping 192.168.10.2
    • Confirm that pings are successful, indicating proper inter-VLAN routing.

Assignment Submission:

  • Lab Report Document:
    • Introduction: Explain the objectives of configuring VLANs and inter-VLAN routing.
    • Execution Steps: Describe each configuration step, linking them to VLAN concepts.
    • Screenshots: Include images of VLAN configurations on switches, router sub-interfaces, IP configurations on PCs, VLAN tables, and successful ping tests.
    • Feedback: Reflect on the process of setting up VLANs and configuring inter-VLAN routing.
    • Learnings: Discuss the benefits of VLANs in network segmentation and management.

Buy Answer of This Assessment & Raise Your Grades

Answer
img-blur-answers
WhatsApp Icon